# CVE-2022-34038: Denial of service in n/a

> Remote attackers can cause a denial of service in etcd via a flaw in the PageWriter write function, though the vendor disputes this classification.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** BIT-etcd-2022-34038, DEBIAN-CVE-2022-34038

## What is CVE-2022-34038?

CVE-2022-34038 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Etcd v3.5.4 allows remote attackers to cause a denial of service via function PageWriter.write in pagewriter.go. NOTE: the vendor's position is that this is not a vulnerability.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-34038?

1 open source package ship an affected version, including etcd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `etcd` | Bitnami | From 3.5.4 | 3.5.5 |

Products: Etcd Etcd.

## How do I fix CVE-2022-34038?

Upgrade etcd to 3.5.5 or later.

## Is CVE-2022-34038 being exploited?

There is no known exploitation of CVE-2022-34038 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)
- [CVE-2020-15106](https://insights.sbomify.com/CVE-2020-15106/): Improper Input Validation in etcd (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34038 and fix it if it is affected.

What it is: CVE-2022-34038 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34038 in the wild and no public exploit code.

Affected packages and fixed versions:
- etcd (Bitnami): affected from 3.5.4; fixed in 3.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34038/ (Markdown: https://insights.sbomify.com/CVE-2022-34038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34038
- OSV: https://osv.dev/vulnerability/CVE-2022-34038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34038/
Summaries are generated and may contain mistakes; the official description above is the record.
