# CVE-2022-34061: Supply chain in n/a

> A backdoor in the Catly-Translate PyPI package allows attackers to execute code, steal sensitive data, and escalate privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-r25f-29pp-6hcv, PYSEC-2022-221

## What is CVE-2022-34061?

CVE-2022-34061 is a critical vulnerability in n/a, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Catly-Translate package in PyPI v0.0.3 to v0.0.5 was discovered to contain a code execution backdoor. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.

## Which versions are affected by CVE-2022-34061?

1 open source package ship an affected version, including catly-translate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `catly-translate` | PyPI | From 0.0.3 | 0.0.6 |

Products: Catly Translate Project Catly Translate.

## How do I fix CVE-2022-34061?

Upgrade catly-translate to 0.0.6 or later.

## Is CVE-2022-34061 being exploited?

There is no known exploitation of CVE-2022-34061 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34061 and fix it if it is affected.

What it is: CVE-2022-34061 is a critical vulnerability in n/a, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34061 in the wild and no public exploit code.

Affected packages and fixed versions:
- catly-translate (PyPI): affected from 0.0.3; fixed in 0.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34061/ (Markdown: https://insights.sbomify.com/CVE-2022-34061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34061
- OSV: https://osv.dev/vulnerability/CVE-2022-34061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34061/
Summaries are generated and may contain mistakes; the official description above is the record.
