# CVE-2022-34112: Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

> Attackers can arbitrarily uninstall plugins in Dataease without administrator privileges, bypassing access controls and modifying system configuration.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-c2pj-rr68-pw94

## What is CVE-2022-34112?

CVE-2022-34112 is a medium-severity missing authorization vulnerability in Dataease Dataease, published on 22 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-34112?

2 open source packages ship an affected version, including io.dataease:dataease-plugin-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.dataease:dataease-plugin-common` | Maven | All versions | 1.11.2 |
| `io.dataease:dataease-plugin-common` | Maven | All versions | 1.11.2 |

Products: Dataease Dataease.

## How do I fix CVE-2022-34112?

Upgrade io.dataease:dataease-plugin-common to 1.11.2 or later.

## Is CVE-2022-34112 being exploited?

There is no known exploitation of CVE-2022-34112 in the wild and no public exploit code.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34112 and fix it if it is affected.

What it is: CVE-2022-34112 is a medium-severity missing authorization vulnerability in Dataease Dataease, published on 22 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34112 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.11.2
- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34112/ (Markdown: https://insights.sbomify.com/CVE-2022-34112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34112
- OSV: https://osv.dev/vulnerability/CVE-2022-34112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34112/
Summaries are generated and may contain mistakes; the official description above is the record.
