{"answers":{"affected":"2 open source packages ship an affected version, including io.dataease:dataease-plugin-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34113 in the wild and no public exploit code.","fix":"Upgrade io.dataease:dataease-plugin-common to 1.11.2 or later.","what":"CVE-2022-34113 is a critical vulnerability in Dataease Dataease, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-34113 and fix it if it is affected.\n\nWhat it is: CVE-2022-34113 is a critical vulnerability in Dataease Dataease, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-34113 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.11.2\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34113/ (Markdown: https://insights.sbomify.com/CVE-2022-34113/index.md)","id":"CVE-2022-34113","markdown":"https://insights.sbomify.com/CVE-2022-34113/index.md","name":"CVE-2022-34113","record":{"aliases":["GHSA-5469-c5p2-xv5g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Dataease BI platform","requires_auth":"none","summary":"Attackers can execute arbitrary code by uploading a malicious plugin to the Dataease application.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"An issue in the component /api/plugin/upload of Dataease v1.11.1 allows attackers to execute arbitrary code via a crafted plugin.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"dataease:dataease","products":["dataease:dataease"],"type":"file_upload","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"SQL Injection found in Dataease","id":"CVE-2022-34114"},"packages":[{"ecosystem":"Maven","fixed":["1.11.2"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":null,"source":"GHSA-5469-c5p2-xv5g"},{"ecosystem":"Maven","fixed":["1.11.2"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":"pkg:maven/io.dataease/dataease-plugin-common","source":"GHSA-5469-c5p2-xv5g"}],"prev":{"headline":"Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin","id":"CVE-2022-34112"},"products":["n/a"],"published":"2022-07-22","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by uploading a malicious plugin to the Dataease application.","url":"https://insights.sbomify.com/CVE-2022-34113/"}