{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.jspwiki:jspwiki-main. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34158 in the wild and no public exploit code.","fix":"Upgrade org.apache.jspwiki:jspwiki-main to 2.11.3 or later.","what":"CVE-2022-34158 is a high-severity vulnerability in Apache JSPWiki, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-34158 and fix it if it is affected.\n\nWhat it is: CVE-2022-34158 is a high-severity vulnerability in Apache JSPWiki, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-34158 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.3\n- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34158/ (Markdown: https://insights.sbomify.com/CVE-2022-34158/index.md)","id":"CVE-2022-34158","markdown":"https://insights.sbomify.com/CVE-2022-34158/index.md","name":"CVE-2022-34158","record":{"aliases":["GHSA-jp3m-p26h-mm7v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache JSPWiki","requires_auth":"none","summary":"A CSRF vulnerability in Apache JSPWiki allows attackers to escalate privileges and take over accounts by modifying email addresses.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"jspwiki","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User Group Privilege Escalation","id":"CVE-2022-34158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in CV81-WDM FW","id":"CVE-2022-34159"},"packages":[{"ecosystem":"Maven","fixed":["2.11.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.jspwiki:jspwiki-main","purl":null,"source":"GHSA-jp3m-p26h-mm7v"},{"ecosystem":"Maven","fixed":["2.11.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.jspwiki:jspwiki-main","purl":"pkg:maven/org.apache.jspwiki/jspwiki-main","source":"GHSA-jp3m-p26h-mm7v"}],"prev":{"headline":"Privilege escalation in Intel(R) FPGA SDK for OpenCL(TM) with Intel(R) Quartus(R) Prime Pro Edition software","id":"CVE-2022-34157"},"products":["Apache JSPWiki"],"published":"2022-08-04","related":[{"cvss_score":9.8,"headline":"Apache JSPWiki: UserManager does not sanity-check user database at startup","id":"CVE-2026-28812","kev_date_added":null,"published":"2026-07-30"},{"cvss_score":9.1,"headline":"Arbitrary file deletion on logout","id":"CVE-2021-44140","kev_date_added":null,"published":"2021-11-24"},{"cvss_score":8.8,"headline":"Apache JSPWiki: JSPWiki vulnerable to JSON hijacking","id":"CVE-2026-28813","kev_date_added":null,"published":"2026-07-30"},{"cvss_score":8.8,"headline":"Apache JSPWiki CSRF Account Takeover","id":"CVE-2022-24947","kev_date_added":null,"published":"2022-02-25"},{"cvss_score":7.5,"headline":"Apache JSPWiki: Error Handling - Reveals Error Details","id":"CVE-2026-28811","kev_date_added":null,"published":"2026-07-30"},{"cvss_score":7.5,"headline":"Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering","id":"CVE-2026-28814","kev_date_added":null,"published":"2026-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"A CSRF vulnerability in Apache JSPWiki allows attackers to escalate privileges and take over accounts by modifying email addresses.","url":"https://insights.sbomify.com/CVE-2022-34158/"}