CVE-2022-34169 Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets
An integer truncation flaw in Apache Xalan allows attackers to execute arbitrary Java bytecode via malicious XSLT stylesheets.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-34169?
CVE-2022-34169 is a high-severity vulnerability in Debian Debian Linux, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.
Weakness: CWE-681
Which versions are affected by CVE-2022-34169?
5 open source packages ship an affected version, including xalan:xalan, java and java-min. It affects 16 products.
| Package | Affected | Fixed in |
|---|---|---|
xalan:xalan Maven | All versions | 2.7.3 |
xalan:xalan Maven | All versions | 2.7.3 |
java Bitnami | From 1.8.0-333 to 1.8.0-333 | None |
java-min Bitnami | From 1.8.0-333 to 1.8.0-333 | None |
jre Bitnami | From 1.8.0-333 to 1.8.0-333 | None |
Linux distribution packages (35)
apache-commons-lang3 SUSE:Enterprise Storage 7.1 | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Enterprise Storage 7.1 | All versions | 6.10.0-150200.11.6.2 |
netty3 SUSE:Enterprise Storage 7.1 | All versions | 3.10.6-150200.3.13.2 |
xalan-j2 SUSE:Enterprise Storage 7.1 | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Enterprise Storage 7.1 | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 6.10.0-150200.11.6.2 |
netty3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 3.10.6-150200.3.13.2 |
xalan-j2 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 6.10.0-150200.11.6.2 |
netty3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 3.10.6-150200.3.13.2 |
xalan-j2 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 6.10.0-150200.11.6.2 |
netty3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 3.10.6-150200.3.13.2 |
xalan-j2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 6.10.0-150200.11.6.2 |
netty3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 3.10.6-150200.3.13.2 |
xalan-j2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 2.12.2-150200.3.10.2 |
bcel SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 6.10.0-150200.11.6.2 |
xalan-j2 SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 3.16.0-150200.3.9.2 |
bcel SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 6.10.0-150200.11.6.2 |
xalan-j2 SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 2.7.3-150200.11.7.1 |
xerces-j2 SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 2.12.2-150200.3.10.2 |
apache-commons-lang3 SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 3.16.0-150200.3.9.2 |
netty3 SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 3.10.6-150200.3.13.2 |
netty3 SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 3.10.6-150200.3.13.2 |
Products include Apache Xalan-Java, Azul Zulu, Debian Debian Linux, Fedoraproject Fedora, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager and 10 more.
How do I fix CVE-2022-34169?
Upgrade xalan:xalan to 2.7.3 or later.
Is CVE-2022-34169 being exploited?
There is no known exploitation of CVE-2022-34169 in the wild and no public exploit code.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-java-2022-34169, BIT-java-min-2022-34169, BIT-jre-2022-34169, CLEANSTART-2026-BP86310, CLEANSTART-2026-IS57850, CLSA-2026-1778028241 and 10 more.