CVE-2022-34170 Cross-site Scripting vulnerability in Jenkins
Attackers with Job/Configure permission can execute arbitrary scripts via unescaped help tooltips, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-34170?
CVE-2022-34170 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Jenkins 2.320 through 2.355 (both inclusive) and LTS 2.332.1 through LTS 2.332.3 (both inclusive) the help icon does not escape the feature name that is part of its tooltip, effectively undoing the fix for SECURITY-1955, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Weakness: CWE-79
Which versions are affected by CVE-2022-34170?
7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | From 2.320 | 2.332.4 |
org.jenkins-ci.main:jenkins-core Maven | From 2.320 | 2.332.4 |
org.jenkins-ci.main:jenkins-core Maven | From 2.346 | 2.346.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.346 | 2.346.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.350 | 2.356 |
org.jenkins-ci.main:jenkins-core Maven | From 2.350 | 2.356 |
1 more packages
jenkins Bitnami | From 2.320.0 | 2.355.1 |
Products include Jenkins Jenkins.
How do I fix CVE-2022-34170?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.332.4, 2.346.1 or 2.356.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-34170 being exploited?
There is no known exploitation of CVE-2022-34170 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2022-34170, GHSA-62wf-24c4-8r76.