CVE-2022-34171 Cross-site Scripting vulnerability in Jenkins
Cross-site scripting vulnerability in Jenkins allows attackers to inject malicious scripts via unescaped SVG icon attributes, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-34171?
CVE-2022-34171 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Jenkins 2.321 through 2.355 (both inclusive) and LTS 2.332.1 through LTS 2.332.3 (both inclusive) the HTML output generated for new symbol-based SVG icons includes the 'title' attribute of 'l:ionicon' (until Jenkins 2.334) and 'alt' attribute of 'l:icon' (since Jenkins 2.335) without further escaping, resulting in a cross-site scripting (XSS) vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2022-34171?
7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.332.4 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.332.4 |
org.jenkins-ci.main:jenkins-core Maven | From 2.346 | 2.346.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.346 | 2.346.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.350 | 2.356 |
org.jenkins-ci.main:jenkins-core Maven | From 2.350 | 2.356 |
1 more packages
jenkins Bitnami | From 2.321.0 | 2.355.1 |
Products include Jenkins Jenkins.
How do I fix CVE-2022-34171?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.332.4, 2.346.1 or 2.356.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-34171 being exploited?
There is no known exploitation of CVE-2022-34171 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2022-34171, GHSA-7f84-p6r5-jr6q.