CVE-2022-34172 Cross-site Scripting vulnerability in Jenkins

Medium 5.4 Published Updated

Attackers can execute arbitrary scripts in victim browsers via unescaped tooltip parameters in Jenkins symbol-based icons.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-34172?

CVE-2022-34172 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In Jenkins 2.340 through 2.355 (both inclusive) symbol-based icons unescape previously escaped values of 'tooltip' parameters, resulting in a cross-site scripting (XSS) vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2022-34172?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenFrom 2.3322.332.4
org.jenkins-ci.main:jenkins-core MavenFrom 2.3322.332.4
org.jenkins-ci.main:jenkins-core MavenFrom 2.3402.356
org.jenkins-ci.main:jenkins-core MavenFrom 2.3402.356
jenkins BitnamiFrom 2.340.02.355.1

Products include Jenkins Jenkins.

How do I fix CVE-2022-34172?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.332.4 or 2.356.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-34172 being exploited?

There is no known exploitation of CVE-2022-34172 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2022-34172, GHSA-mhp7-3393-pfqr.

Is CVE-2022-34172 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free