# CVE-2022-34176: Cross-site Scripting in Jenkins JUnit Plugin

> Attackers with Run/Update permission can inject malicious scripts into test result descriptions, leading to stored XSS attacks against Jenkins users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-64mj-3p92-589v

## What is CVE-2022-34176?

CVE-2022-34176 is a medium-severity cross-site scripting vulnerability in Jenkins JUnit Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-34176?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:junit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:junit` | Maven | All versions | 1119.1121.vc43d0fc45561 |
| `org.jenkins-ci.plugins:junit` | Maven | All versions | 1119.1121.vc43d0fc45561 |

Products: Jenkins Junit.

## How do I fix CVE-2022-34176?

Upgrade org.jenkins-ci.plugins:junit to 1119.1121.vc43d0fc45561 or later.

## Is CVE-2022-34176 being exploited?

There is no known exploitation of CVE-2022-34176 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins JUnit Plugin

- [CVE-2018-1000056](https://insights.sbomify.com/CVE-2018-1000056/): Improper Restriction of XML External Entity Reference in Jenkins JUnit Plugin (high 8.3)
- [CVE-2018-1000411](https://insights.sbomify.com/CVE-2018-1000411/): Jenkins JUnit Plugin CSRF vulnerability (medium 6.5)
- [CVE-2023-25761](https://insights.sbomify.com/CVE-2023-25761/): Cross-site Scripting in Jenkins JUnit Plugin (medium 5.4)
- [CVE-2022-45380](https://insights.sbomify.com/CVE-2022-45380/): Jenkins JUnit Plugin subject to Cross-site Scripting via URL conversion (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34176 and fix it if it is affected.

What it is: CVE-2022-34176 is a medium-severity cross-site scripting vulnerability in Jenkins JUnit Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-34176 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:junit (Maven): affected all versions; fixed in 1119.1121.vc43d0fc45561
- org.jenkins-ci.plugins:junit (Maven): affected all versions; fixed in 1119.1121.vc43d0fc45561

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34176/ (Markdown: https://insights.sbomify.com/CVE-2022-34176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34176
- OSV: https://osv.dev/vulnerability/CVE-2022-34176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34176/
Summaries are generated and may contain mistakes; the official description above is the record.
