# CVE-2022-34180: Improper authorization in Jenkins Embeddable Build Status Plugin bypasses ViewStatus permission requirement

> Attackers can access build status badges for any job without permissions due to a missing authorization check in the Jenkins Embeddable Build Status Plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xxhf-xq6v-c8mj

## What is CVE-2022-34180?

CVE-2022-34180 is a high-severity missing authorization vulnerability in Jenkins Embeddable Build Status Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Embeddable Build Status Plugin 2.0.3 and earlier does not correctly perform the ViewStatus permission check in the HTTP endpoint it provides for "unprotected" status badge access, allowing attackers without any permissions to obtain the build status badge icon for any attacker-specified job and/or build.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-34180?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:embeddable-build-status. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:embeddable-build-status` | Maven | All versions | 2.0.4 |
| `org.jenkins-ci.plugins:embeddable-build-status` | Maven | All versions | 2.0.4 |

Products: Jenkins Embeddable Build Status.

## How do I fix CVE-2022-34180?

Upgrade org.jenkins-ci.plugins:embeddable-build-status to 2.0.4 or later.

## Is CVE-2022-34180 being exploited?

There is no known exploitation of CVE-2022-34180 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Embeddable Build Status Plugin

- [CVE-2022-34179](https://insights.sbomify.com/CVE-2022-34179/): Path Traversal vulnerability in Jenkins Embeddable Build Status Plugin (high 7.5)
- [CVE-2022-34178](https://insights.sbomify.com/CVE-2022-34178/): Reflected Cross site scripting in Jenkins Embeddable Build Status Plugin (medium 6.1)
- [CVE-2019-10346](https://insights.sbomify.com/CVE-2019-10346/): Jenkins Embeddable Build Status Plugin contains Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34180 and fix it if it is affected.

What it is: CVE-2022-34180 is a high-severity missing authorization vulnerability in Jenkins Embeddable Build Status Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34180 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:embeddable-build-status (Maven): affected all versions; fixed in 2.0.4
- org.jenkins-ci.plugins:embeddable-build-status (Maven): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34180/ (Markdown: https://insights.sbomify.com/CVE-2022-34180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34180
- OSV: https://osv.dev/vulnerability/CVE-2022-34180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34180/
Summaries are generated and may contain mistakes; the official description above is the record.
