# CVE-2022-34181: Agent-to-controller security bypass in Jenkins xUnit Plugin

> Attackers controlling agent processes can create arbitrary directories or read test results from existing files on the Jenkins controller.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-298j-9q4w-6rm4

## What is CVE-2022-34181?

CVE-2022-34181 is a critical path traversal vulnerability in Jenkins xUnit Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins xUnit Plugin 3.0.8 and earlier implements an agent-to-controller message that creates a user-specified directory if it doesn't exist, and parsing files inside it as test results, allowing attackers able to control agent processes to create an arbitrary directory on the Jenkins controller or to obtain test results from existing files in an attacker-specified directory.

## Which versions are affected by CVE-2022-34181?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:xunit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:xunit` | Maven | All versions | 3.1.0 |
| `org.jenkins-ci.plugins:xunit` | Maven | All versions | 3.1.0 |

Products: Jenkins Xunit.

## How do I fix CVE-2022-34181?

Upgrade org.jenkins-ci.plugins:xunit to 3.1.0 or later.

## Is CVE-2022-34181 being exploited?

There is no known exploitation of CVE-2022-34181 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34181 and fix it if it is affected.

What it is: CVE-2022-34181 is a critical path traversal vulnerability in Jenkins xUnit Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34181 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:xunit (Maven): affected all versions; fixed in 3.1.0
- org.jenkins-ci.plugins:xunit (Maven): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34181/ (Markdown: https://insights.sbomify.com/CVE-2022-34181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34181
- OSV: https://osv.dev/vulnerability/CVE-2022-34181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34181/
Summaries are generated and may contain mistakes; the official description above is the record.
