{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:nested-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34182 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:nested-view to 1.26 or later.","what":"CVE-2022-34182 is a medium-severity cross-site scripting vulnerability in Jenkins Nested View Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-34182 and fix it if it is affected.\n\nWhat it is: CVE-2022-34182 is a medium-severity cross-site scripting vulnerability in Jenkins Nested View Plugin, published on 22 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-34182 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:nested-view (Maven): affected from 1.20; fixed in 1.26\n- org.jenkins-ci.plugins:nested-view (Maven): affected from 1.20; fixed in 1.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34182/ (Markdown: https://insights.sbomify.com/CVE-2022-34182/index.md)","id":"CVE-2022-34182","markdown":"https://insights.sbomify.com/CVE-2022-34182/index.md","name":"CVE-2022-34182","record":{"aliases":["GHSA-h642-5h74-3x9c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Nested View Plugin","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via unescaped search parameters in the Jenkins Nested View Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"nested_view","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Nested View Plugin 1.20 through 1.25 (both inclusive) does not escape search parameters, resulting in a reflected cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected Cross-site Scripting in Jenkins Nested View Plugin","id":"CVE-2022-34182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site Scripting in Jenkins Agent Server Parameter Plugin","id":"CVE-2022-34183"},"packages":[{"ecosystem":"Maven","fixed":["1.26"],"introduced":["1.20"],"last_affected":[],"package":"org.jenkins-ci.plugins:nested-view","purl":null,"source":"GHSA-h642-5h74-3x9c"},{"ecosystem":"Maven","fixed":["1.26"],"introduced":["1.20"],"last_affected":[],"package":"org.jenkins-ci.plugins:nested-view","purl":"pkg:maven/org.jenkins-ci.plugins/nested-view","source":"GHSA-h642-5h74-3x9c"}],"prev":{"headline":"Agent-to-controller security bypass in Jenkins xUnit Plugin","id":"CVE-2022-34181"},"products":["Jenkins Nested View Plugin"],"published":"2022-06-22","related":[{"cvss_score":7.1,"headline":"XXE vulnerability in Jenkins Nested View Plugin","id":"CVE-2021-21680","kev_date_added":null,"published":"2021-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via unescaped search parameters in the Jenkins Nested View Plugin.","url":"https://insights.sbomify.com/CVE-2022-34182/"}