# CVE-2022-34188: Cross-site Scripting in Jenkins Hidden Parameter Plugin

> Stored XSS in Jenkins Hidden Parameter Plugin allows attackers with configure permissions to execute scripts in other users' browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jhfv-8936-g652

## What is CVE-2022-34188?

CVE-2022-34188 is a medium-severity cross-site scripting vulnerability in Jenkins Hidden Parameter Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Hidden Parameter Plugin 0.0.4 and earlier does not escape the name and description of Hidden Parameter parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-34188?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:hidden-parameter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:hidden-parameter` | Maven | All versions | 0.0.5 |
| `org.jenkins-ci.plugins:hidden-parameter` | Maven | All versions | 0.0.5 |

Products: Jenkins Hidden Parameter.

## How do I fix CVE-2022-34188?

Upgrade org.jenkins-ci.plugins:hidden-parameter to 0.0.5 or later.

## Is CVE-2022-34188 being exploited?

There is no known exploitation of CVE-2022-34188 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34188 and fix it if it is affected.

What it is: CVE-2022-34188 is a medium-severity cross-site scripting vulnerability in Jenkins Hidden Parameter Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-34188 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:hidden-parameter (Maven): affected all versions; fixed in 0.0.5
- org.jenkins-ci.plugins:hidden-parameter (Maven): affected all versions; fixed in 0.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34188/ (Markdown: https://insights.sbomify.com/CVE-2022-34188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34188
- OSV: https://osv.dev/vulnerability/CVE-2022-34188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34188/
Summaries are generated and may contain mistakes; the official description above is the record.
