{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:cavisson-ns-nd-integration. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34191 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:cavisson-ns-nd-integration to 4.8.0.129 or later.","what":"CVE-2022-34191 is a medium-severity cross-site scripting vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-34191 and fix it if it is affected.\n\nWhat it is: CVE-2022-34191 is a medium-severity cross-site scripting vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin, published on 22 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-34191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.129\n- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): affected all versions; fixed in 4.8.0.129\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34191/ (Markdown: https://insights.sbomify.com/CVE-2022-34191/index.md)","id":"CVE-2022-34191","markdown":"https://insights.sbomify.com/CVE-2022-34191/index.md","name":"CVE-2022-34191","record":{"aliases":["GHSA-pv38-mqpp-v72h"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins NS-ND Integration Performance Publisher Plugin allows attackers with configure permissions to execute scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"ns-nd_integration_performance_publisher","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Jenkins NS-ND Integration Performance Publisher Plugin","id":"CVE-2022-34191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site Scripting in Jenkins ontrack Jenkins Plugin","id":"CVE-2022-34192"},"packages":[{"ecosystem":"Maven","fixed":["4.8.0.129"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:cavisson-ns-nd-integration","purl":null,"source":"GHSA-pv38-mqpp-v72h"},{"ecosystem":"Maven","fixed":["4.8.0.129"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:cavisson-ns-nd-integration","purl":"pkg:maven/io.jenkins.plugins/cavisson-ns-nd-integration","source":"GHSA-pv38-mqpp-v72h"}],"prev":{"headline":"Cross-site Scripting in Jenkins Maven Metadata Plugin","id":"CVE-2022-34190"},"products":["Jenkins NS-ND Integration Performance Publisher Plugin"],"published":"2022-06-22","related":[{"cvss_score":8.8,"headline":"Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2022-41227","kev_date_added":null,"published":"2022-09-21"},{"cvss_score":8.8,"headline":"Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Missing Authorization","id":"CVE-2022-41228","kev_date_added":null,"published":"2022-09-21"},{"cvss_score":7.5,"headline":"Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking","id":"CVE-2023-33000","kev_date_added":null,"published":"2023-05-16"},{"cvss_score":7.5,"headline":"SSL/TLS certificate validation unconditionally disabled by Jenkins NS-ND Integration Performance Publisher Plugin","id":"CVE-2022-38666","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":7.5,"headline":"Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally","id":"CVE-2022-45391","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":6.5,"headline":"Plaintext Storage of a Password in Jenkins NS-ND Integration Performance Publisher Plugin","id":"CVE-2022-45392","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":5.4,"headline":"Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-site Scripting","id":"CVE-2022-41229","kev_date_added":null,"published":"2022-09-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins NS-ND Integration Performance Publisher Plugin allows attackers with configure permissions to execute scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2022-34191/"}