{"answers":{"affected":"2 open source packages ship an affected version, including nocodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-3423 in the wild and no public exploit code.","fix":"Upgrade nocodb to 0.92.0 or later.","what":"CVE-2022-3423 is a high-severity denial of service vulnerability in nocodb/nocodb, published on 7 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-3423 and fix it if it is affected.\n\nWhat it is: CVE-2022-3423 is a high-severity denial of service vulnerability in nocodb/nocodb, published on 7 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-3423 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nocodb (npm): affected all versions; fixed in 0.92.0\n- nocodb (npm): affected all versions; fixed in 0.92.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3423/ (Markdown: https://insights.sbomify.com/CVE-2022-3423/index.md)","id":"CVE-2022-3423","markdown":"https://insights.sbomify.com/CVE-2022-3423/index.md","name":"CVE-2022-3423","record":{"aliases":["GHSA-grv6-m753-3w2g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"NocoDB application","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in NocoDB by exploiting resource allocation limits, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"nocodb","vendor":"nocodb"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Allocation of Resources Without Limits or Throttling in GitHub repository nocodb/nocodb prior to 0.92.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Allocation of Resources Without Limits or Throttling in nocodb/nocodb","id":"CVE-2022-3423","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in kernel","id":"CVE-2022-3424"},"packages":[{"ecosystem":"npm","fixed":["0.92.0"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":null,"source":"GHSA-grv6-m753-3w2g"},{"ecosystem":"npm","fixed":["0.92.0"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":"pkg:npm/nocodb","source":"GHSA-grv6-m753-3w2g"}],"prev":{"headline":"Improper Privilege Management in tooljet/tooljet","id":"CVE-2022-3422"},"products":["nocodb/nocodb"],"published":"2022-10-07","related":[{"cvss_score":9.1,"headline":"Server-Side Request Forgery (SSRF) in nocodb/nocodb","id":"CVE-2022-2339","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":9.1,"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9.1,"headline":"Insufficient Session Expiration in nocodb/nocodb","id":"CVE-2022-2064","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Improper Privilege Management in nocodb/nocodb","id":"CVE-2022-2063","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) - Stored in nocodb/nocodb","id":"CVE-2022-2022","kev_date_added":null,"published":"2022-06-07"},{"cvss_score":8.5,"headline":"NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload","id":"CVE-2026-24769","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8,"headline":"NocoDB - CSV Injection in User Management","id":"CVE-2022-22121","kev_date_added":null,"published":"2022-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nocodb"]},"summary":"Attackers can cause denial of service in NocoDB by exploiting resource allocation limits, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-3423/"}