CVE-2022-34253 Adobe Commerce XML Injection Arbitrary code execution
An attacker with admin privileges can achieve remote code execution via XML injection in the Widgets Module of Adobe Commerce.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-34253?
CVE-2022-34253 is a critical vulnerability in Adobe Commerce, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution. Exploitation of this issue does not require user interaction.
Weakness: CWE-91
Which versions are affected by CVE-2022-34253?
7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.7-p4 |
magento/community-edition Packagist | All versions | 2.3.7-p4 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
1 more packages
magento Bitnami | From 2.3.0 to 2.3.7-p1 | 2.3.7, 2.4.3 |
Products include Adobe Commerce, Magento Magento.
How do I fix CVE-2022-34253?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.
Is CVE-2022-34253 being exploited?
There is no known exploitation of CVE-2022-34253 in the wild and no public exploit code.
Other vulnerabilities in Adobe Commerce
- CVE-2026-75650 Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine
- CVE-2024-34102 Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)
- CVE-2022-24086 Adobe Commerce and Magento Open Source Improper Input Validation
- CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type
- CVE-2026-71362 Adobe Commerce and Magento Incorrect Authorization Vulnerability
Sources
Also known as BIT-magento-2022-34253, GHSA-cj7w-pm77-hvg6.