CVE-2022-34254 Adobe Commerce Improper Limitation of a Pathname to a Restricted Directory Arbitrary code execution
A low-privileged attacker can exploit a path traversal flaw in Adobe Commerce to read local files and inject malicious scripts, leading to potential code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-34254?
CVE-2022-34254 is a high-severity path traversal vulnerability in Adobe Commerce, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.
Weakness: CWE-22
Which versions are affected by CVE-2022-34254?
7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.3.0 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.3.0 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
1 more packages
magento Bitnami | From 2.3.0 to 2.3.7-p1 | 2.3.7, 2.4.3 |
Products include Adobe Commerce, Magento Magento.
How do I fix CVE-2022-34254?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2022-34254 being exploited?
There is no known exploitation of CVE-2022-34254 in the wild and no public exploit code.
Other vulnerabilities in Adobe Commerce
- CVE-2026-75650 Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine
- CVE-2024-34102 Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)
- CVE-2022-24086 Adobe Commerce and Magento Open Source Improper Input Validation
- CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type
- CVE-2026-71362 Adobe Commerce and Magento Incorrect Authorization Vulnerability
Sources
Also known as BIT-magento-2022-34254, GHSA-fx9g-g9q6-x3jx.