# CVE-2022-34255: Adobe Commerce Improper Access Control Privilege escalation

> Adobe Commerce allows low-privilege attackers to escalate privileges and take over victim accounts without user interaction.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-magento-2022-34255, GHSA-x95x-f4g9-mm85

## What is CVE-2022-34255?

CVE-2022-34255 is a high-severity vulnerability in Adobe Commerce, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-34255?

7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.7-p4 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.7-p4 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p3 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p3 |
| `magento/community-edition` | Packagist | From 2.4.4 | 2.4.5 |
| `magento/community-edition` | Packagist | From 2.4.4 | 2.4.5 |
| `magento` | Bitnami | From 2.3.0 to 2.3.7-p1 | 2.3.7, 2.4.3 |

Products: Adobe Commerce, Magento Magento.

## How do I fix CVE-2022-34255?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.

## Is CVE-2022-34255 being exploited?

There is no known exploitation of CVE-2022-34255 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34255 and fix it if it is affected.

What it is: CVE-2022-34255 is a high-severity vulnerability in Adobe Commerce, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34255 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.7-p4
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.7-p4
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3
- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5
- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5
- magento (Bitnami): affected from 2.3.0 up to 2.3.7-p1; fixed in 2.3.7, 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34255/ (Markdown: https://insights.sbomify.com/CVE-2022-34255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34255
- OSV: https://osv.dev/vulnerability/CVE-2022-34255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34255/
Summaries are generated and may contain mistakes; the official description above is the record.
