CVE-2022-34257 Adobe Commerce Stored XSS Arbitrary code execution
Attackers can inject malicious scripts into Adobe Commerce form fields, leading to arbitrary code execution in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-34257?
CVE-2022-34257 is a medium-severity cross-site scripting vulnerability in Adobe Commerce, published on 16 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Weakness: CWE-79
Which versions are affected by CVE-2022-34257?
7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.3.0 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.3.0 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.0 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
magento/community-edition Packagist | From 2.4.4 | 2.4.5 |
1 more packages
magento Bitnami | From 2.3.0 to 2.3.7-p1 | 2.3.7, 2.4.3 |
Products include Adobe Commerce, Magento Magento.
How do I fix CVE-2022-34257?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-34257 being exploited?
There is no known exploitation of CVE-2022-34257 in the wild and no public exploit code.
Other vulnerabilities in Adobe Commerce
- CVE-2026-75650 Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine
- CVE-2024-34102 Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)
- CVE-2022-24086 Adobe Commerce and Magento Open Source Improper Input Validation
- CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type
- CVE-2026-71362 Adobe Commerce and Magento Incorrect Authorization Vulnerability
Sources
Also known as BIT-magento-2022-34257, GHSA-rg7p-wmgj-f374.