CVE-2022-34258 Adobe Commerce Stored XSS Arbitrary code execution

Medium 4.8 Published Updated

An attacker with admin privileges can inject malicious scripts into form fields, leading to arbitrary code execution in victims' browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-34258?

CVE-2022-34258 is a medium-severity cross-site scripting vulnerability in Adobe Commerce, published on 16 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Weakness: CWE-79

Which versions are affected by CVE-2022-34258?

7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.3.02.3.7-p4
magento/community-edition PackagistFrom 2.3.02.3.7-p4
magento/community-edition PackagistFrom 2.4.02.4.3-p3
magento/community-edition PackagistFrom 2.4.02.4.3-p3
magento/community-edition PackagistFrom 2.4.42.4.5
magento/community-edition PackagistFrom 2.4.42.4.5
1 more packages
magento BitnamiFrom 2.3.0 to 2.3.7-p12.3.7, 2.4.3

Products include Adobe Commerce, Magento Magento.

How do I fix CVE-2022-34258?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-34258 being exploited?

There is no known exploitation of CVE-2022-34258 in the wild and no public exploit code.

All Adobe Commerce vulnerabilities

Sources

Also known as BIT-magento-2022-34258, GHSA-5m55-g8pv-x8ww.

Is CVE-2022-34258 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free