# CVE-2022-34265: Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection

> Attackers can execute arbitrary SQL commands via untrusted input in Django's Trunc and Extract database functions, potentially compromising data integrity and confidentiality.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jul 2022
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-django-2022-34265, DEBIAN-CVE-2022-34265, GHSA-p64x-8rxx-wf6q, PYSEC-2022-213, RHSA-2022:5738, UBUNTU-CVE-2022-34265, USN-5501-1, openSUSE-SU-2024:12172-1

## What is CVE-2022-34265?

CVE-2022-34265 is a critical SQL injection vulnerability in Djangoproject Django, published on 4 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. The Trunc() and Extract() database functions are subject to SQL injection if untrusted data is used as a kind/lookup_name value. Applications that constrain the lookup name and kind choice to a known safe list are unaffected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-34265?

6 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.14, 4.0.6 |
| `django` | PyPI | From 3.2 | 3.2.14, 4.0.6 |
| `django` | PyPI | From 3.2a1 | 3.2.14 |
| `django` | PyPI | From 4.0a1 | 4.0.6 |
| `Django` | PyPI | From 3.2a1 | 3.2.14 |
| `Django` | PyPI | From 4.0a1 | 4.0.6 |
| `python-django` | Red Hat:rhui:4::el8 | All versions | 0:3.2.14-3.el8ui |
| `python38-django` | Red Hat:rhui:4::el8 | All versions | 0:3.2.14-3.el8ui |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.0.6-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2022-34265?

Upgrade django to a fixed version for your release line: 3.2.14 or 4.0.6.

## Is CVE-2022-34265 being exploited?

There is no known exploitation of CVE-2022-34265 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2022-34265 (Django) (github_poc): https://github.com/aeyesec/CVE-2022-34265
- PoC for CVE-2022-34265 (github_poc): https://github.com/ZhaoQi99/CVE-2022-34265
- CVE-2022-34265 Vulnerability  (github_poc): https://github.com/traumatising/CVE-2022-34265
- https://github.com/lnwza0x0a/CTF_Django_CVE-2022-34265 (github_poc): https://github.com/lnwza0x0a/CTF_Django_CVE-2022-34265
- Vulhub django/CVE-2022-34265: Django Trunc and Extract SQL Injection (CVE-2022-34265), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-django-cve-2022-34265

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2021-35042](https://insights.sbomify.com/CVE-2021-35042/): SQL Injection in Django (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34265 and fix it if it is affected.

What it is: CVE-2022-34265 is a critical SQL injection vulnerability in Djangoproject Django, published on 4 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34265 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.14, 4.0.6
- django (PyPI): affected from 3.2; fixed in 3.2.14, 4.0.6
- django (PyPI): affected from 3.2a1; fixed in 3.2.14
- django (PyPI): affected from 4.0a1; fixed in 4.0.6
- Django (PyPI): affected from 3.2a1; fixed in 3.2.14
- Django (PyPI): affected from 4.0a1; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34265/ (Markdown: https://insights.sbomify.com/CVE-2022-34265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34265
- OSV: https://osv.dev/vulnerability/CVE-2022-34265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34265/
Summaries are generated and may contain mistakes; the official description above is the record.
