{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34298 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-core to 14.6.6 or later.","what":"CVE-2022-34298 is a medium-severity vulnerability in n/a, published on 22 Jun 2022."},"fix_prompt":"Check this codebase for CVE-2022-34298 and fix it if it is affected.\n\nWhat it is: CVE-2022-34298 is a medium-severity vulnerability in n/a, published on 22 Jun 2022. \nExploitation: There is no known exploitation of CVE-2022-34298 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 14.6.6\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 14.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34298/ (Markdown: https://insights.sbomify.com/CVE-2022-34298/index.md)","id":"CVE-2022-34298","markdown":"https://insights.sbomify.com/CVE-2022-34298/index.md","name":"CVE-2022-34298","record":{"aliases":["GHSA-px3r-27qc-hx5g"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"openam","vendor":"openidentityplatform"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[],"description":"The NT auth module in OpenAM before 14.6.6 allows a \"replace Samba username attack.\"","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2022-06-22","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-06-22T14:38:59Z","kind":"github_poc","ref":"https://github.com/watchtowrlabs/CVE-2022-34298","stars":2,"title":"PoC exploit for CVE-2022-34298, OpenAM authentication bypass"}],"tier":"poc_unverified"},"has_fix":true,"headline":"NT auth module vulnerability in OpenAM","id":"CVE-2022-34298","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-34299"},"packages":[{"ecosystem":"Maven","fixed":["14.6.6"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":null,"source":"GHSA-px3r-27qc-hx5g"},{"ecosystem":"Maven","fixed":["14.6.6"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":"pkg:maven/org.openidentityplatform.openam/openam-core","source":"GHSA-px3r-27qc-hx5g"}],"prev":{"headline":"Yii2 Gii Cross-site Scripting vulnerability","id":"CVE-2022-34297"},"products":["n/a"],"published":"2022-06-22","related":[{"cvss_score":9.3,"headline":"Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM","id":"CVE-2026-33439","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":9.1,"headline":"User impersonation using SAMLv1.x SSO in Open Access Management","id":"CVE-2023-37471","kev_date_added":null,"published":"2023-07-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-34298/"}