CVE-2022-34321 Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint

High 8.2 Published Updated

Unauthenticated attackers can access proxy statistics and modify logging levels, potentially causing denial of service and exposing connection details.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-34321?

CVE-2022-34321 is a high-severity missing authorization vulnerability in Apache Pulsar, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials.

This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0.

The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer's default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to "Cluster" by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren't known to be exposed.

2.10 Pulsar Proxy users should upgrade to at least 2.10.6. 2.11 Pulsar Proxy users should upgrade to at least 2.11.3. 3.0 Pulsar Proxy users should upgrade to at least 3.0.2. 3.1 Pulsar Proxy users should upgrade to at least 3.1.1.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it's imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.

Weakness: CWE-306

Which versions are affected by CVE-2022-34321?

8 open source packages ship an affected version, including org.apache.pulsar:pulsar-proxy. It affects 1 product.

PackageAffectedFixed in
org.apache.pulsar:pulsar-proxy MavenFrom 2.11.02.11.3
org.apache.pulsar:pulsar-proxy MavenFrom 2.11.02.11.3
org.apache.pulsar:pulsar-proxy MavenFrom 2.6.02.10.6
org.apache.pulsar:pulsar-proxy MavenFrom 2.6.02.10.6
org.apache.pulsar:pulsar-proxy MavenFrom 3.0.03.0.2
org.apache.pulsar:pulsar-proxy MavenFrom 3.0.03.0.2
2 more packages
org.apache.pulsar:pulsar-proxy MavenFrom 3.1.03.1.1
org.apache.pulsar:pulsar-proxy MavenFrom 3.1.03.1.1

Products include Apache Pulsar.

How do I fix CVE-2022-34321?

Upgrade org.apache.pulsar:pulsar-proxy to a fixed version for your release line: 2.11.3, 2.10.6, 3.0.2 or 3.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-34321 being exploited?

There is no known exploitation of CVE-2022-34321 in the wild and no public exploit code.

Sources

Also known as GHSA-c35h-w8hj-mm55.

Is CVE-2022-34321 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free