# CVE-2022-34321: Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint

> Unauthenticated attackers can access proxy statistics and modify logging levels, potentially causing denial of service and exposing connection details.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-c35h-w8hj-mm55

## What is CVE-2022-34321?

CVE-2022-34321 is a high-severity missing authorization vulnerability in Apache Pulsar, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials.

This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0.

The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer's default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to "Cluster" by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren't known to be exposed.

2.10 Pulsar Proxy users should upgrade to at least 2.10.6.
2.11 Pulsar Proxy users should upgrade to at least 2.11.3.
3.0 Pulsar Proxy users should upgrade to at least 3.0.2.
3.1 Pulsar Proxy users should upgrade to at least 3.1.1.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it's imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2022-34321?

8 open source packages ship an affected version, including org.apache.pulsar:pulsar-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.11.0 | 2.11.3 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.11.0 | 2.11.3 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.6.0 | 2.10.6 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 2.6.0 | 2.10.6 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 3.1.0 | 3.1.1 |
| `org.apache.pulsar:pulsar-proxy` | Maven | From 3.1.0 | 3.1.1 |

Products: Apache Pulsar.

## How do I fix CVE-2022-34321?

Upgrade org.apache.pulsar:pulsar-proxy to a fixed version for your release line: 2.11.3, 2.10.6, 3.0.2 or 3.1.1.

## Is CVE-2022-34321 being exploited?

There is no known exploitation of CVE-2022-34321 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34321 and fix it if it is affected.

What it is: CVE-2022-34321 is a high-severity missing authorization vulnerability in Apache Pulsar, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34321 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.11.0; fixed in 2.11.3
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.11.0; fixed in 2.11.3
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.6.0; fixed in 2.10.6
- org.apache.pulsar:pulsar-proxy (Maven): affected from 2.6.0; fixed in 2.10.6
- org.apache.pulsar:pulsar-proxy (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.pulsar:pulsar-proxy (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.pulsar:pulsar-proxy (Maven): affected from 3.1.0; fixed in 3.1.1
- org.apache.pulsar:pulsar-proxy (Maven): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34321/ (Markdown: https://insights.sbomify.com/CVE-2022-34321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34321
- OSV: https://osv.dev/vulnerability/CVE-2022-34321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34321/
Summaries are generated and may contain mistakes; the official description above is the record.
