# CVE-2022-3433: Denial of service in aeson

> A remote attacker can cause a denial of service in applications using the aeson library by sending specially crafted JSON data that triggers hash collisions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-3433, GHSA-p383-f595-x4qw, HSEC-2023-0001, UBUNTU-CVE-2022-3433

## What is CVE-2022-3433?

CVE-2022-3433 is a medium-severity denial of service vulnerability in aeson, published on 10 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The aeson library is not safe to use to consume untrusted JSON input. A remote user could abuse this flaw to produce a hash collision in the underlying unordered-containers library by sending specially crafted JSON data, resulting in a denial of service.

Weakness: CWE-326 (Inadequate Encryption Strength), CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2022-3433?

1 open source package ship an affected version, including aeson. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aeson` | Hackage | From 0.4.0.0 | 2.0.1.0 |

Products: Haskell Aeson.

## How do I fix CVE-2022-3433?

Upgrade aeson to 2.0.1.0 or later.

## Is CVE-2022-3433 being exploited?

There is no known exploitation of CVE-2022-3433 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3433 and fix it if it is affected.

What it is: CVE-2022-3433 is a medium-severity denial of service vulnerability in aeson, published on 10 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3433 in the wild and no public exploit code.

Affected packages and fixed versions:
- aeson (Hackage): affected from 0.4.0.0; fixed in 2.0.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3433/ (Markdown: https://insights.sbomify.com/CVE-2022-3433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3433
- OSV: https://osv.dev/vulnerability/CVE-2022-3433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3433/
Summaries are generated and may contain mistakes; the official description above is the record.
