# CVE-2022-34558: WMAgent arbitrary code execution via a crafted dbs-client package

> Attackers can execute arbitrary code in WMAgent and related tools by supplying a malicious dbs-client package.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4vq7-8699-4xgc, PYSEC-2022-43136, PYSEC-2022-43163, PYSEC-2022-43174, PYSEC-2026-523

## What is CVE-2022-34558?

CVE-2022-34558 is a critical code injection vulnerability in n/a, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr 2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and global-workqueue 1.4.1rc5 allows attackers to execute arbitrary code via a crafted dbs-client package.

## Which versions are affected by CVE-2022-34558?

12 open source packages ship an affected version, including global-workqueue, reqmgr2 and reqmon. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `global-workqueue` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `global-workqueue` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `global-workqueue` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `reqmgr2` | PyPI | From 1.4.0rc2 | 2.0.4 |
| `reqmgr2` | PyPI | From 1.4.0rc2 | 2.0.4 |
| `reqmgr2` | PyPI | From 1.4.0rc2 | 2.0.4 |
| `reqmon` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `reqmon` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `reqmon` | PyPI | From 1.4.1rc5 | 2.0.4 |
| `wmagent` | PyPI | From 1.3.3rc1 | 2.0.4 |
| `wmagent` | PyPI | From 1.3.3rc1 | 2.0.4 |
| `wmagent` | PyPI | From 1.3.3rc1 | 2.0.4 |

Products: Global-Workqueue Project Global-Workqueue, Reqmgr2 Project Reqmgr2, Reqmon Project Reqmon, Wmagent Project Wmagent.

## How do I fix CVE-2022-34558?

Upgrade global-workqueue to 2.0.4 or later.

## Is CVE-2022-34558 being exploited?

There is no known exploitation of CVE-2022-34558 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34558 and fix it if it is affected.

What it is: CVE-2022-34558 is a critical code injection vulnerability in n/a, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34558 in the wild and no public exploit code.

Affected packages and fixed versions:
- global-workqueue (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- global-workqueue (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- global-workqueue (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- reqmgr2 (PyPI): affected from 1.4.0rc2; fixed in 2.0.4
- reqmgr2 (PyPI): affected from 1.4.0rc2; fixed in 2.0.4
- reqmgr2 (PyPI): affected from 1.4.0rc2; fixed in 2.0.4
- reqmon (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- reqmon (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- reqmon (PyPI): affected from 1.4.1rc5; fixed in 2.0.4
- wmagent (PyPI): affected from 1.3.3rc1; fixed in 2.0.4
- wmagent (PyPI): affected from 1.3.3rc1; fixed in 2.0.4
- wmagent (PyPI): affected from 1.3.3rc1; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34558/ (Markdown: https://insights.sbomify.com/CVE-2022-34558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34558
- OSV: https://osv.dev/vulnerability/CVE-2022-34558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34558/
Summaries are generated and may contain mistakes; the official description above is the record.
