# CVE-2022-34749: Mistune vulnerable to catastrophic backtracking

> An attacker can cause a denial of service in the mistune library by triggering catastrophic backtracking in regular expressions during inline markup processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-10403, DEBIAN-CVE-2022-34749, GHSA-fw3v-x4f2-v673, PYSEC-2022-237, UBUNTU-CVE-2022-34749, openSUSE-SU-2024:12350-1, openSUSE-SU-2025:14637-1

## What is CVE-2022-34749?

CVE-2022-34749 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In mistune through 2.0.2, support of inline markup is implemented by using regular expressions that can involve a high amount of backtracking on certain edge cases. This behavior is commonly named catastrophic backtracking.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-34749?

3 open source packages ship an affected version, including mistune. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistune` | PyPI | From 2.0.0a1 | 2.0.3 |
| `mistune` | PyPI | From 2.0.0a1 | 2.0.3 |
| `mistune` | PyPI | From 2.0.0a1 | 2.0.3 |
| `python-mistune` | openSUSE:Tumbleweed | All versions | 3.1.0-1.1 |

Products: Fedoraproject Fedora, Mistune Project Mistune.

## How do I fix CVE-2022-34749?

Upgrade mistune to 2.0.3 or later.

## Is CVE-2022-34749 being exploited?

There is no known exploitation of CVE-2022-34749 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34749 and fix it if it is affected.

What it is: CVE-2022-34749 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34749 in the wild and no public exploit code.

Affected packages and fixed versions:
- mistune (PyPI): affected from 2.0.0a1; fixed in 2.0.3
- mistune (PyPI): affected from 2.0.0a1; fixed in 2.0.3
- mistune (PyPI): affected from 2.0.0a1; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34749/ (Markdown: https://insights.sbomify.com/CVE-2022-34749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34749
- OSV: https://osv.dev/vulnerability/CVE-2022-34749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34749/
Summaries are generated and may contain mistakes; the official description above is the record.
