{"answers":{"affected":"1 open source package ship an affected version, including mediawiki. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34750 in the wild and no public exploit code.","fix":"Upgrade mediawiki to 1.38.2 or later.","what":"CVE-2022-34750 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-34750 and fix it if it is affected.\n\nWhat it is: CVE-2022-34750 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-34750 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.38.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34750/ (Markdown: https://insights.sbomify.com/CVE-2022-34750/index.md)","id":"CVE-2022-34750","markdown":"https://insights.sbomify.com/CVE-2022-34750/index.md","name":"CVE-2022-34750","record":{"aliases":["BIT-mediawiki-2022-34750","GHSA-vh8m-7c3c-7m5c"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki Wikibase extension","requires_auth":"none","summary":"Attackers can create oversized Wikibase lexemes due to missing length validation, causing denial of service in MediaWiki installations using Wikibase extensions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"An issue was discovered in MediaWiki through 1.38.1. The lemma length of a Wikibase lexeme is currently capped at a thousand characters. Unfortunately, this length is not validated, allowing much larger lexemes to be created, which introduces various denial-of-service attack vectors within the Wikibase and WikibaseLexeme extensions. This is related to Special:NewLexeme and Special:NewProperty.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-34750","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mediawiki:mediawiki","products":["mediawiki:mediawiki"],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Command injection in SpaceLogic C-Bus Home Controller","id":"CVE-2022-34753"},"packages":[{"ecosystem":"Bitnami","fixed":["1.38.2"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2022-34750"}],"prev":{"headline":"Mistune vulnerable to catastrophic backtracking","id":"CVE-2022-34749"},"products":["n/a"],"published":"2022-06-28","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2023-37303","kev_date_added":null,"published":"2023-06-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-29904","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-29906","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2022-28205","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28206","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28209","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2021-36126","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can create oversized Wikibase lexemes due to missing length validation, causing denial of service in MediaWiki installations using Wikibase extensions.","url":"https://insights.sbomify.com/CVE-2022-34750/"}