# CVE-2022-34777: Cross-site Scripting in Jenkins GitLab Plugin

> Stored XSS in Jenkins GitLab Plugin allows attackers with configure permissions to inject scripts into build descriptions, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-f655-xhvm-cwp4

## What is CVE-2022-34777?

CVE-2022-34777 is a medium-severity cross-site scripting vulnerability in Jenkins GitLab Plugin, published on 30 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of webhook-triggered builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-34777?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:gitlab-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gitlab-plugin` | Maven | All versions | 1.5.35 |
| `org.jenkins-ci.plugins:gitlab-plugin` | Maven | All versions | 1.5.35 |

Products: Jenkins Gitlab.

## How do I fix CVE-2022-34777?

Upgrade org.jenkins-ci.plugins:gitlab-plugin to 1.5.35 or later.

## Is CVE-2022-34777 being exploited?

There is no known exploitation of CVE-2022-34777 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins GitLab Plugin

- [CVE-2019-10301](https://insights.sbomify.com/CVE-2019-10301/): Jenkins GitLab Plugin missing permission checks (high 8.8)
- [CVE-2019-10300](https://insights.sbomify.com/CVE-2019-10300/): Jenkins GitLab Plugin Cross-Site Request Forgery vulnerability (high 8.0)
- [CVE-2022-30955](https://insights.sbomify.com/CVE-2022-30955/): Missing permission check in Jenkins GitLab Plugin (medium 6.5)
- [CVE-2022-43411](https://insights.sbomify.com/CVE-2022-43411/): Non-constant time webhook token comparison in Jenkins GitLab Plugin (medium 5.3)
- [CVE-2025-24397](https://insights.sbomify.com/CVE-2025-24397/): Incorrect permission check in Jenkins GitLab Plugin allows enumerating credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34777 and fix it if it is affected.

What it is: CVE-2022-34777 is a medium-severity cross-site scripting vulnerability in Jenkins GitLab Plugin, published on 30 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-34777 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gitlab-plugin (Maven): affected all versions; fixed in 1.5.35
- org.jenkins-ci.plugins:gitlab-plugin (Maven): affected all versions; fixed in 1.5.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34777/ (Markdown: https://insights.sbomify.com/CVE-2022-34777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34777
- OSV: https://osv.dev/vulnerability/CVE-2022-34777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34777/
Summaries are generated and may contain mistakes; the official description above is the record.
