CVE-2022-3478 File upload in GitLab
Attackers can cause denial of service in GitLab by uploading malicious NuGet packages, requiring administrators to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3478?
CVE-2022-3478 is a medium-severity vulnerability in Gitlab Gitlab, published on 24 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 12.8 before 15.4.6, all versions starting from 15.5 before 15.5.5, all versions starting from 15.6 before 15.6.1. It was possible to trigger a DoS attack by uploading a malicious nuget package.
Weakness: CWE-434
Which versions are affected by CVE-2022-3478?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.8.0 | 15.4.6, 15.5.5, 15.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3478?
Upgrade gitlab to a fixed version for your release line: 15.4.6, 15.5.5 or 15.6.1.
Is CVE-2022-3478 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3478 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3478, GHSA-h782-mprg-p5xv, UBUNTU-CVE-2022-3478.