# CVE-2022-34782: Incorrect Authorization in Jenkins requests-plugin

> Attackers with read permissions can view pending requests due to incorrect permission checks in the Jenkins requests-plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6xhf-xx3j-75f5

## What is CVE-2022-34782?

CVE-2022-34782 is a medium-severity missing authorization vulnerability in Jenkins requests-plugin Plugin, published on 30 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An incorrect permission check in Jenkins requests-plugin Plugin 2.2.16 and earlier allows attackers with Overall/Read permission to view the list of pending requests.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-34782?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:requests. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:requests` | Maven | All versions | 2.2.17 |
| `org.jenkins-ci.plugins:requests` | Maven | All versions | 2.2.17 |

Products: Jenkins Requests.

## How do I fix CVE-2022-34782?

Upgrade org.jenkins-ci.plugins:requests to 2.2.17 or later.

## Is CVE-2022-34782 being exploited?

There is no known exploitation of CVE-2022-34782 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins requests-plugin Plugin

- [CVE-2021-21675](https://insights.sbomify.com/CVE-2021-21675/): CSRF vulnerabilities in Jenkins requests-plugin Plugin (medium 6.5)
- [CVE-2021-21674](https://insights.sbomify.com/CVE-2021-21674/): Missing permission check in Jenkins requests-plugin Plugin allows viewing pending requests (medium 4.3)
- [CVE-2021-21676](https://insights.sbomify.com/CVE-2021-21676/): Missing permission check in Jenkins requests-plugin Plugin allows sending emails (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34782 and fix it if it is affected.

What it is: CVE-2022-34782 is a medium-severity missing authorization vulnerability in Jenkins requests-plugin Plugin, published on 30 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34782 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:requests (Maven): affected all versions; fixed in 2.2.17
- org.jenkins-ci.plugins:requests (Maven): affected all versions; fixed in 2.2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34782/ (Markdown: https://insights.sbomify.com/CVE-2022-34782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34782
- OSV: https://osv.dev/vulnerability/CVE-2022-34782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34782/
Summaries are generated and may contain mistakes; the official description above is the record.
