CVE-2022-34867 WordPress WP Libre Form 2 plugin <= 2.0.8 - Unauthenticated Sensitive Information Disclosure vulnerability
Unauthenticated attackers can list and delete form submissions in the WP Libre Form 2 plugin, exposing sensitive data and causing data loss.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-34867?
CVE-2022-34867 is a high-severity vulnerability in Libreform WP Libre Form 2 (WordPress plugin), published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Unauthenticated Sensitive Information Disclosure vulnerability in WP Libre Form 2 plugin <= 2.0.8 at WordPress allows attackers to list and delete submissions. Affects only versions from 2.0.0 to 2.0.8.
Which versions are affected by CVE-2022-34867?
2 open source packages ship an affected version, including libreform/libreform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libreform/libreform Packagist | From 2.0.0 | 2.0.9 |
libreform/libreform Packagist | From 2.0.0 | 2.0.9 |
Products include Wp Libre Form Project Wp Libre Form.
How do I fix CVE-2022-34867?
Upgrade libreform/libreform to 2.0.9 or later.
Is CVE-2022-34867 being exploited?
There is no known exploitation of CVE-2022-34867 in the wild and no public exploit code.
Sources
Also known as GHSA-29qv-hhg4-6x96.