{"answers":{"affected":"2 open source packages ship an affected version, including libreform/libreform. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34867 in the wild and no public exploit code.","fix":"Upgrade libreform/libreform to 2.0.9 or later.","what":"CVE-2022-34867 is a high-severity vulnerability in Libreform WP Libre Form 2 (WordPress plugin), published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-34867 and fix it if it is affected.\n\nWhat it is: CVE-2022-34867 is a high-severity vulnerability in Libreform WP Libre Form 2 (WordPress plugin), published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-34867 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libreform/libreform (Packagist): affected from 2.0.0; fixed in 2.0.9\n- libreform/libreform (Packagist): affected from 2.0.0; fixed in 2.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34867/ (Markdown: https://insights.sbomify.com/CVE-2022-34867/index.md)","id":"CVE-2022-34867","markdown":"https://insights.sbomify.com/CVE-2022-34867/index.md","name":"CVE-2022-34867","record":{"aliases":["GHSA-29qv-hhg4-6x96"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can list and delete form submissions in the WP Libre Form 2 plugin, exposing sensitive data and causing data loss.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"wp_libre_form","vendor":"wp_libre_form_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Unauthenticated Sensitive Information Disclosure vulnerability in WP Libre Form 2 plugin \u003c= 2.0.8 at WordPress allows attackers to list and delete submissions. Affects only versions from 2.0.0 to 2.0.8.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress WP Libre Form 2 plugin \u003c= 2.0.8 - Unauthenticated Sensitive Information Disclosure vulnerability","id":"CVE-2022-34867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress ЮKassa для WooCommerce plugin \u003c= 2.3.0 - Authenticated Arbitrary Settings Update vulnerability","id":"CVE-2022-34868"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.9"],"introduced":["2.0.0"],"last_affected":[],"package":"libreform/libreform","purl":null,"source":"GHSA-29qv-hhg4-6x96"},{"ecosystem":"Packagist","fixed":["2.0.9"],"introduced":["2.0.0"],"last_affected":[],"package":"libreform/libreform","purl":"pkg:composer/libreform/libreform","source":"GHSA-29qv-hhg4-6x96"}],"prev":{"headline":"Command injection in Passage Drive","id":"CVE-2022-34866"},"products":["WP Libre Form 2 (WordPress plugin)"],"published":"2022-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Libreform"]},"summary":"Unauthenticated attackers can list and delete form submissions in the WP Libre Form 2 plugin, exposing sensitive data and causing data loss.","url":"https://insights.sbomify.com/CVE-2022-34867/"}