# CVE-2022-34867: WordPress WP Libre Form 2 plugin <= 2.0.8 - Unauthenticated Sensitive Information Disclosure vulnerability

> Unauthenticated attackers can list and delete form submissions in the WP Libre Form 2 plugin, exposing sensitive data and causing data loss.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2022
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-29qv-hhg4-6x96

## What is CVE-2022-34867?

CVE-2022-34867 is a high-severity vulnerability in Libreform WP Libre Form 2 (WordPress plugin), published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unauthenticated Sensitive Information Disclosure vulnerability in WP Libre Form 2 plugin <= 2.0.8 at WordPress allows attackers to list and delete submissions. Affects only versions from 2.0.0 to 2.0.8.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-34867?

2 open source packages ship an affected version, including libreform/libreform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libreform/libreform` | Packagist | From 2.0.0 | 2.0.9 |
| `libreform/libreform` | Packagist | From 2.0.0 | 2.0.9 |

Products: Wp Libre Form Project Wp Libre Form.

## How do I fix CVE-2022-34867?

Upgrade libreform/libreform to 2.0.9 or later.

## Is CVE-2022-34867 being exploited?

There is no known exploitation of CVE-2022-34867 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34867 and fix it if it is affected.

What it is: CVE-2022-34867 is a high-severity vulnerability in Libreform WP Libre Form 2 (WordPress plugin), published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34867 in the wild and no public exploit code.

Affected packages and fixed versions:
- libreform/libreform (Packagist): affected from 2.0.0; fixed in 2.0.9
- libreform/libreform (Packagist): affected from 2.0.0; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34867/ (Markdown: https://insights.sbomify.com/CVE-2022-34867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34867
- OSV: https://osv.dev/vulnerability/CVE-2022-34867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34867/
Summaries are generated and may contain mistakes; the official description above is the record.
