CVE-2022-34870 Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application

Medium 5.4 Published Updated

Attackers can inject malicious scripts into the Apache Geode Pulse web application, potentially executing code or stealing data from users viewing region entries.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-34870?

CVE-2022-34870 is a medium-severity cross-site scripting vulnerability in Apache Geode, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.

Weakness: CWE-79

Which versions are affected by CVE-2022-34870?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.

PackageAffectedFixed in
org.apache.geode:geode-core MavenAll versions1.15.1
org.apache.geode:geode-core MavenAll versions1.15.1

Products include Apache Geode.

How do I fix CVE-2022-34870?

Upgrade org.apache.geode:geode-core to 1.15.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-34870 being exploited?

There is no known exploitation of CVE-2022-34870 in the wild and no public exploit code.

Sources

Also known as GHSA-373r-9mg8-3jc4.

Is CVE-2022-34870 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free