# CVE-2022-34870: Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application

> Attackers can inject malicious scripts into the Apache Geode Pulse web application, potentially executing code or stealing data from users viewing region entries.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 9 May 2025
- **Also known as:** GHSA-373r-9mg8-3jc4

## What is CVE-2022-34870?

CVE-2022-34870 is a medium-severity cross-site scripting vulnerability in Apache Geode, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-34870?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-core` | Maven | All versions | 1.15.1 |
| `org.apache.geode:geode-core` | Maven | All versions | 1.15.1 |

Products: Apache Geode.

## How do I fix CVE-2022-34870?

Upgrade org.apache.geode:geode-core to 1.15.1 or later.

## Is CVE-2022-34870 being exploited?

There is no known exploitation of CVE-2022-34870 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2022-37021](https://insights.sbomify.com/CVE-2022-37021/): Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. (critical 9.8)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2017-15692](https://insights.sbomify.com/CVE-2017-15692/): Apache Geode unsafe deserialization in TcpServer (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34870 and fix it if it is affected.

What it is: CVE-2022-34870 is a medium-severity cross-site scripting vulnerability in Apache Geode, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-34870 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.15.1
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34870/ (Markdown: https://insights.sbomify.com/CVE-2022-34870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34870
- OSV: https://osv.dev/vulnerability/CVE-2022-34870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34870/
Summaries are generated and may contain mistakes; the official description above is the record.
