# CVE-2022-34914: Command injection in n/a

> Attackers can inject arbitrary arguments into session startup via manipulated X-Forwarded-For headers if the clientIp variable is used in configuration.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-38x3-v328-497c

## What is CVE-2022-34914?

CVE-2022-34914 is a critical command injection vulnerability in n/a, published on 8 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Webswing before 22.1.3 allows X-Forwarded-For header injection. The client IP address is associated with a variable in the configuration page. The {clientIp} variable can be used as an application startup argument. The X-Forwarded-For header can be manipulated by a client to store an arbitrary value that is used to replace the clientIp variable (without sanitization). A client can thus inject multiple arguments into the session startup. Systems that do not use the clientIP variable in the configuration are not vulnerable. The vulnerability is fixed in these versions: 20.1.16, 20.2.19, 21.1.8, 21.2.12, and 22.1.3.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-34914?

It affects 1 product.


Products: Webswing Webswing.

## How do I fix CVE-2022-34914?

No fix has been published for CVE-2022-34914 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-34914 being exploited?

There is no known exploitation of CVE-2022-34914 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-39332](https://insights.sbomify.com/CVE-2024-39332/): Path traversal in n/a (critical 9.8)
- [CVE-2020-11103](https://insights.sbomify.com/CVE-2020-11103/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34914 and fix it if it is affected.

What it is: CVE-2022-34914 is a critical command injection vulnerability in n/a, published on 8 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34914 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34914/ (Markdown: https://insights.sbomify.com/CVE-2022-34914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34914
- OSV: https://osv.dev/vulnerability/CVE-2022-34914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34914/
Summaries are generated and may contain mistakes; the official description above is the record.
