{"answers":{"affected":"1 open source package ship an affected version, including pycrowdtangle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-34981 in the wild and no public exploit code.","fix":"Upgrade pycrowdtangle to 0.0.3 or later.","what":"CVE-2022-34981 is a critical vulnerability in n/a, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-34981 and fix it if it is affected.\n\nWhat it is: CVE-2022-34981 is a critical vulnerability in n/a, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-34981 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycrowdtangle (PyPI): affected from 0.0.1; fixed in 0.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-34981/ (Markdown: https://insights.sbomify.com/CVE-2022-34981/index.md)","id":"CVE-2022-34981","markdown":"https://insights.sbomify.com/CVE-2022-34981/index.md","name":"CVE-2022-34981","record":{"aliases":["GHSA-hwrh-8hxh-8cqh","PYSEC-2022-242"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package","requires_auth":"none","summary":"A backdoor in the PyCrowdTangle package allows attackers to execute arbitrary code on systems installing the malicious version.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pycrowdtangle","vendor":"pycrowdtangle_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"The PyCrowdTangle package in PyPI before v0.0.1 included a code execution backdoor inserted by a third party.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Supply chain in n/a","id":"CVE-2022-34981","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Supply chain in n/a","id":"CVE-2022-34982"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.3"],"introduced":["0.0.1"],"last_affected":[],"package":"pycrowdtangle","purl":"pkg:pypi/pycrowdtangle","source":"PYSEC-2022-242"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2022-34974"},"products":["n/a"],"published":"2022-07-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A backdoor in the PyCrowdTangle package allows attackers to execute arbitrary code on systems installing the malicious version.","url":"https://insights.sbomify.com/CVE-2022-34981/"}