# CVE-2022-34981: Supply chain in n/a

> A backdoor in the PyCrowdTangle package allows attackers to execute arbitrary code on systems installing the malicious version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hwrh-8hxh-8cqh, PYSEC-2022-242

## What is CVE-2022-34981?

CVE-2022-34981 is a critical vulnerability in n/a, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The PyCrowdTangle package in PyPI before v0.0.1 included a code execution backdoor inserted by a third party.

## Which versions are affected by CVE-2022-34981?

1 open source package ship an affected version, including pycrowdtangle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycrowdtangle` | PyPI | From 0.0.1 | 0.0.3 |

Products: Pycrowdtangle Project Pycrowdtangle.

## How do I fix CVE-2022-34981?

Upgrade pycrowdtangle to 0.0.3 or later.

## Is CVE-2022-34981 being exploited?

There is no known exploitation of CVE-2022-34981 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-34981 and fix it if it is affected.

What it is: CVE-2022-34981 is a critical vulnerability in n/a, published on 22 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-34981 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycrowdtangle (PyPI): affected from 0.0.1; fixed in 0.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-34981/ (Markdown: https://insights.sbomify.com/CVE-2022-34981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-34981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-34981
- OSV: https://osv.dev/vulnerability/CVE-2022-34981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-34981/
Summaries are generated and may contain mistakes; the official description above is the record.
