# CVE-2022-3500: Keylime: unhandled exceptions could lead to invalid attestation states

> A rogue agent can trigger exceptions in the Keylime verifier, causing denial of service and leaving hosts in an unverified but attested state.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** ALSA-2022:8444, GHSA-hff2-x2j9-gxgv, PYSEC-2022-42995, RHSA-2022:8444, RLSA-2022:8444, SUSE-SU-2022:4204-1

## What is CVE-2022-3500?

CVE-2022-3500 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in keylime. This security issue happens in some circumstances, due to some improperly handled exceptions, there exists the possibility that a rogue agent could create errors on the verifier that stopped attestation attempts for that host leaving it in an attested state but not verifying that anymore.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2022-3500?

3 open source packages ship an affected version, including keylime. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keylime` | PyPI | All versions | 6.5.1 |
| `keylime` | PyPI | All versions | 6.5.1 |
| `keylime` | PyPI | All versions | 6.5.1 |
| `keylime` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime-base` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime-registrar` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime-selinux` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime-tenant` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime-verifier` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `python3-keylime` | AlmaLinux:9 | All versions | 6.5.1-1.el9_1 |
| `keylime` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime-base` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime-registrar` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime-selinux` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime-tenant` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime-verifier` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `python3-keylime` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.1-1.el9_1 |
| `keylime` | Rocky Linux:9 | All versions | 0:6.5.1-1.el9_1.4 |
| `keylime` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 6.3.2-150400.4.14.1 |
| `keylime` | openSUSE:Leap 15.4 | All versions | 6.3.2-150400.4.14.1 |

Products: Fedoraproject Fedora, Keylime Keylime, Redhat Enterprise Linux.

## How do I fix CVE-2022-3500?

Upgrade keylime to 6.5.1 or later.

## Is CVE-2022-3500 being exploited?

There is no known exploitation of CVE-2022-3500 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3500 and fix it if it is affected.

What it is: CVE-2022-3500 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3500 in the wild and no public exploit code.

Affected packages and fixed versions:
- keylime (PyPI): affected all versions; fixed in 6.5.1
- keylime (PyPI): affected all versions; fixed in 6.5.1
- keylime (PyPI): affected all versions; fixed in 6.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3500/ (Markdown: https://insights.sbomify.com/CVE-2022-3500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3500
- OSV: https://osv.dev/vulnerability/CVE-2022-3500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3500/
Summaries are generated and may contain mistakes; the official description above is the record.
