CVE-2022-3510 Parsing issue in protobuf message-type extension
Attackers can cause denial of service via long garbage collection pauses by sending crafted protobuf messages with specific embedded fields.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3510?
CVE-2022-3510 is a high-severity denial of service vulnerability in Google ProtocolBuffers, published on 11 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.
Weakness: CWE-400
Which versions are affected by CVE-2022-3510?
16 open source packages ship an affected version, including com.google.protobuf:protobuf-java and com.google.protobuf:protobuf-javalite. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.google.protobuf:protobuf-java Maven | From 3.0.0 | 3.16.3 |
com.google.protobuf:protobuf-java Maven | From 3.0.0 | 3.16.3 |
com.google.protobuf:protobuf-java Maven | From 3.17.0 | 3.19.6 |
com.google.protobuf:protobuf-java Maven | From 3.17.0 | 3.19.6 |
com.google.protobuf:protobuf-java Maven | From 3.20.0 | 3.20.3 |
com.google.protobuf:protobuf-java Maven | From 3.20.0 | 3.20.3 |
10 more packages
com.google.protobuf:protobuf-java Maven | From 3.21.0 | 3.21.7 |
com.google.protobuf:protobuf-java Maven | From 3.21.0 | 3.21.7 |
com.google.protobuf:protobuf-javalite Maven | From 3.0.0 | 3.16.3 |
com.google.protobuf:protobuf-javalite Maven | From 3.0.0 | 3.16.3 |
com.google.protobuf:protobuf-javalite Maven | From 3.17.0 | 3.19.6 |
com.google.protobuf:protobuf-javalite Maven | From 3.17.0 | 3.19.6 |
com.google.protobuf:protobuf-javalite Maven | From 3.20.0 | 3.20.3 |
com.google.protobuf:protobuf-javalite Maven | From 3.20.0 | 3.20.3 |
com.google.protobuf:protobuf-javalite Maven | From 3.21.0 | 3.21.7 |
com.google.protobuf:protobuf-javalite Maven | From 3.21.0 | 3.21.7 |
Products include Google Protobuf-Java, Google Protobuf-Javalite.
How do I fix CVE-2022-3510?
Upgrade com.google.protobuf:protobuf-java to a fixed version for your release line: 3.16.3, 3.19.6, 3.20.3 or 3.21.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-3510 being exploited?
There is no known exploitation of CVE-2022-3510 in the wild and no public exploit code.
Other vulnerabilities in Google ProtocolBuffers
Sources
Also known as CLEANSTART-2026-BF52327, CLEANSTART-2026-UD96949, DEBIAN-CVE-2022-3510, ECHO-2e49-78c2-5329, GHSA-4gg5-vx3j-xwc7, MINI-232m-5jr4-994g and 8 more.