# CVE-2022-3510: Parsing issue in protobuf message-type extension

> Attackers can cause denial of service via long garbage collection pauses by sending crafted protobuf messages with specific embedded fields.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLEANSTART-2026-BF52327, CLEANSTART-2026-UD96949, DEBIAN-CVE-2022-3510, ECHO-2e49-78c2-5329, GHSA-4gg5-vx3j-xwc7, MINI-232m-5jr4-994g, MINI-45wq-8fvq-hc4r, MINI-4cgp-w2cj-pxh4, MINI-8jhv-v524-r9h6, MINI-h755-7w62-fp47, MINI-pf2j-f836-mr77, MINI-rg8v-cg6j-hvhm, ROOT-APP-MAVEN-CVE-2022-3510, UBUNTU-CVE-2022-3510

## What is CVE-2022-3510?

CVE-2022-3510 is a high-severity denial of service vulnerability in Google ProtocolBuffers, published on 11 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-3510?

16 open source packages ship an affected version, including com.google.protobuf:protobuf-java and com.google.protobuf:protobuf-javalite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.google.protobuf:protobuf-java` | Maven | From 3.0.0 | 3.16.3 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.0.0 | 3.16.3 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.17.0 | 3.19.6 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.17.0 | 3.19.6 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.20.0 | 3.20.3 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.20.0 | 3.20.3 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.21.0 | 3.21.7 |
| `com.google.protobuf:protobuf-java` | Maven | From 3.21.0 | 3.21.7 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.0.0 | 3.16.3 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.0.0 | 3.16.3 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.17.0 | 3.19.6 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.17.0 | 3.19.6 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.20.0 | 3.20.3 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.20.0 | 3.20.3 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.21.0 | 3.21.7 |
| `com.google.protobuf:protobuf-javalite` | Maven | From 3.21.0 | 3.21.7 |

Products: Google Protobuf-Java, Google Protobuf-Javalite.

## How do I fix CVE-2022-3510?

Upgrade com.google.protobuf:protobuf-java to a fixed version for your release line: 3.16.3, 3.19.6, 3.20.3 or 3.21.7.

## Is CVE-2022-3510 being exploited?

There is no known exploitation of CVE-2022-3510 in the wild and no public exploit code.

## Other vulnerabilities in Google ProtocolBuffers

- [CVE-2022-3509](https://insights.sbomify.com/CVE-2022-3509/): Parsing issue in protobuf textformat (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3510 and fix it if it is affected.

What it is: CVE-2022-3510 is a high-severity denial of service vulnerability in Google ProtocolBuffers, published on 11 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3510 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.google.protobuf:protobuf-java (Maven): affected from 3.0.0; fixed in 3.16.3
- com.google.protobuf:protobuf-java (Maven): affected from 3.0.0; fixed in 3.16.3
- com.google.protobuf:protobuf-java (Maven): affected from 3.17.0; fixed in 3.19.6
- com.google.protobuf:protobuf-java (Maven): affected from 3.17.0; fixed in 3.19.6
- com.google.protobuf:protobuf-java (Maven): affected from 3.20.0; fixed in 3.20.3
- com.google.protobuf:protobuf-java (Maven): affected from 3.20.0; fixed in 3.20.3
- com.google.protobuf:protobuf-java (Maven): affected from 3.21.0; fixed in 3.21.7
- com.google.protobuf:protobuf-java (Maven): affected from 3.21.0; fixed in 3.21.7
- com.google.protobuf:protobuf-javalite (Maven): affected from 3.0.0; fixed in 3.16.3
- com.google.protobuf:protobuf-javalite (Maven): affected from 3.0.0; fixed in 3.16.3
- com.google.protobuf:protobuf-javalite (Maven): affected from 3.17.0; fixed in 3.19.6
- com.google.protobuf:protobuf-javalite (Maven): affected from 3.17.0; fixed in 3.19.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3510/ (Markdown: https://insights.sbomify.com/CVE-2022-3510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3510
- OSV: https://osv.dev/vulnerability/CVE-2022-3510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3510/
Summaries are generated and may contain mistakes; the official description above is the record.
