CVE-2022-3513 Cross-site scripting in GitLab

Medium 6.1 Published Updated

Reflected XSS in GitLab allows attackers to perform arbitrary actions on behalf of victims on self-hosted instances without strict CSP.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-3513?

CVE-2022-3513 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 12.8 before 15.8.5, all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A specially crafted payload could lead to a reflected XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims on self-hosted instances running without strict CSP.

Weakness: CWE-79

Which versions are affected by CVE-2022-3513?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.8.015.8.5, 15.9.4, 15.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-3513?

Upgrade gitlab to a fixed version for your release line: 15.8.5, 15.9.4 or 15.10.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-3513 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3513 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3513, GHSA-8w2x-795m-pv4v, UBUNTU-CVE-2022-3513.

Is CVE-2022-3513 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free