# CVE-2022-35131: Joplin is vulnerable to arbitrary code execution

> Attackers can execute arbitrary commands via crafted payloads in Node titles, requiring users to upgrade Joplin.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2022
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-ww2v-frv5-pj5x

## What is CVE-2022-35131?

CVE-2022-35131 is a critical cross-site scripting vulnerability in n/a, published on 25 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Joplin v2.8.8 allows attackers to execute arbitrary commands via a crafted payload injected into the Node titles.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-35131?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 2.9.1 |
| `joplin` | npm | All versions | 2.9.1 |

Products: Joplinapp Joplin.

## How do I fix CVE-2022-35131?

Upgrade joplin to 2.9.1 or later.

## Is CVE-2022-35131 being exploited?

There is no known exploitation of CVE-2022-35131 in the wild and no public exploit code.

Public exploit code:

- Joplin CVE-2022-35131, RCE (github_poc): https://github.com/ly1g3/Joplin-CVE-2022-35131

## Other vulnerabilities in n/a

- [CVE-2026-22810](https://insights.sbomify.com/CVE-2026-22810/): Joplin: Path traversal in OneNote importer allows overwriting arbitrary files (high 8.2)
- [CVE-2022-40277](https://insights.sbomify.com/CVE-2022-40277/): Joplin Remote Code Execution (high 7.8)
- [CVE-2021-23431](https://insights.sbomify.com/CVE-2021-23431/): Cross-site Request Forgery (CSRF) (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35131 and fix it if it is affected.

What it is: CVE-2022-35131 is a critical cross-site scripting vulnerability in n/a, published on 25 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35131 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 2.9.1
- joplin (npm): affected all versions; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35131/ (Markdown: https://insights.sbomify.com/CVE-2022-35131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35131
- OSV: https://osv.dev/vulnerability/CVE-2022-35131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35131/
Summaries are generated and may contain mistakes; the official description above is the record.
