# CVE-2022-35143: Raneto v0.17.0 employs weak password complexity requirements

> Weak password complexity in Renato allows attackers to crack user passwords via brute-force attacks, leading to account takeover.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7942-2fx8-qhpf

## What is CVE-2022-35143?

CVE-2022-35143 is a critical vulnerability in n/a, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Renato v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2022-35143?

2 open source packages ship an affected version, including raneto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `raneto` | npm | All versions | 0.17.1 |
| `raneto` | npm | All versions | 0.17.1 |

Products: Raneto Project Raneto.

## How do I fix CVE-2022-35143?

Upgrade raneto to 0.17.1 or later.

## Is CVE-2022-35143 being exploited?

There is no known exploitation of CVE-2022-35143 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-35142](https://insights.sbomify.com/CVE-2022-35142/): Raneto Denial of Service via crafted payload injected into `Search` parameter (high 7.5)
- [CVE-2022-35144](https://insights.sbomify.com/CVE-2022-35144/): Raneto vulnerable to Cross-site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35143 and fix it if it is affected.

What it is: CVE-2022-35143 is a critical vulnerability in n/a, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35143 in the wild and no public exploit code.

Affected packages and fixed versions:
- raneto (npm): affected all versions; fixed in 0.17.1
- raneto (npm): affected all versions; fixed in 0.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35143/ (Markdown: https://insights.sbomify.com/CVE-2022-35143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35143
- OSV: https://osv.dev/vulnerability/CVE-2022-35143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35143/
Summaries are generated and may contain mistakes; the official description above is the record.
