# CVE-2022-35144: Raneto vulnerable to Cross-site Scripting

> An XSS vulnerability in the Renato library allows attackers to inject malicious scripts, potentially leading to code execution in the user's browser.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vc68-6x72-w22f

## What is CVE-2022-35144?

CVE-2022-35144 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Renato v0.17.0 was discovered to contain a cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-35144?

2 open source packages ship an affected version, including raneto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `raneto` | npm | All versions | 0.17.1 |
| `raneto` | npm | All versions | 0.17.1 |

Products: Raneto Project Raneto.

## How do I fix CVE-2022-35144?

Upgrade raneto to 0.17.1 or later.

## Is CVE-2022-35144 being exploited?

There is no known exploitation of CVE-2022-35144 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-35143](https://insights.sbomify.com/CVE-2022-35143/): Raneto v0.17.0 employs weak password complexity requirements (critical 9.8)
- [CVE-2022-35142](https://insights.sbomify.com/CVE-2022-35142/): Raneto Denial of Service via crafted payload injected into `Search` parameter (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35144 and fix it if it is affected.

What it is: CVE-2022-35144 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35144 in the wild and no public exploit code.

Affected packages and fixed versions:
- raneto (npm): affected all versions; fixed in 0.17.1
- raneto (npm): affected all versions; fixed in 0.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35144/ (Markdown: https://insights.sbomify.com/CVE-2022-35144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35144
- OSV: https://osv.dev/vulnerability/CVE-2022-35144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35144/
Summaries are generated and may contain mistakes; the official description above is the record.
