# CVE-2022-3517: minimatch ReDoS vulnerability

> Attackers can cause a Denial of Service in the minimatch library by triggering a Regular Expression Denial of Service via the braceExpand function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2022
- **Updated:** 13 May 2025
- **Also known as:** AZL-44451, AZL-44946, CLSA-2026-1774484498, CLSA-2026-1774484507, DEBIAN-CVE-2022-3517, DLA-3271-1, GHSA-f8q6-p94x-37v3, MINI-mc6x-4858-333p, OESA-2022-2028, ROOT-APP-NPM-CVE-2022-3517, UBUNTU-CVE-2022-3517, USN-6086-1

## What is CVE-2022-3517?

CVE-2022-3517 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in the minimatch package. This flaw allows a Regular Expression Denial of Service (ReDoS) when calling the braceExpand function with specific arguments, resulting in a Denial of Service.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-3517?

2 open source packages ship an affected version, including minimatch. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `minimatch` | npm | All versions | 3.0.5 |
| `minimatch` | npm | All versions | 3.0.5 |

Products: Debian Debian Linux, Fedoraproject Fedora, Minimatch Project Minimatch.

## How do I fix CVE-2022-3517?

Upgrade minimatch to 3.0.5 or later.

## Is CVE-2022-3517 being exploited?

There is no known exploitation of CVE-2022-3517 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3517 and fix it if it is affected.

What it is: CVE-2022-3517 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3517 in the wild and no public exploit code.

Affected packages and fixed versions:
- minimatch (npm): affected all versions; fixed in 3.0.5
- minimatch (npm): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3517/ (Markdown: https://insights.sbomify.com/CVE-2022-3517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3517
- OSV: https://osv.dev/vulnerability/CVE-2022-3517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3517/
Summaries are generated and may contain mistakes; the official description above is the record.
