# CVE-2022-3525: Deserialization of Untrusted Data in librenms/librenms

> An attacker can execute arbitrary code by exploiting unsafe deserialization in LibreNMS, requiring an upgrade to the latest version.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-cv9g-h8mm-xx5h

## What is CVE-2022-3525?

CVE-2022-3525 is a critical unsafe deserialization vulnerability in Librenms Librenms, published on 20 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data in GitHub repository librenms/librenms prior to 22.10.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-3525?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 22.10.0 |
| `librenms/librenms` | Packagist | All versions | 22.10.0 |

Products: Librenms Librenms.

## How do I fix CVE-2022-3525?

Upgrade librenms/librenms to 22.10.0 or later.

## Is CVE-2022-3525 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3525 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3525 and fix it if it is affected.

What it is: CVE-2022-3525 is a critical unsafe deserialization vulnerability in Librenms Librenms, published on 20 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3525 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 22.10.0
- librenms/librenms (Packagist): affected all versions; fixed in 22.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3525/ (Markdown: https://insights.sbomify.com/CVE-2022-3525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3525
- OSV: https://osv.dev/vulnerability/CVE-2022-3525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3525/
Summaries are generated and may contain mistakes; the official description above is the record.
