CVE-2022-35513 Blink1Control2 uses weak password encryption

High 7.5 Published Updated

Attackers can decrypt stored credentials due to weak encryption, potentially leading to unauthorized access to the Blink1Control2 application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-35513?

CVE-2022-35513 is a high-severity vulnerability in n/a, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Blink1Control2 application <= 2.2.7 uses weak password encryption and an insecure method of storage.

Weakness: CWE-922, CWE-327

Which versions are affected by CVE-2022-35513?

2 open source packages ship an affected version, including Blink1Control2. It affects 1 product.

PackageAffectedFixed in
Blink1Control2 npmAll versions2.2.9
Blink1Control2 npmAll versions2.2.9

Products include Blink1 Blink1control2.

How do I fix CVE-2022-35513?

Upgrade Blink1Control2 to 2.2.9 or later.

Is CVE-2022-35513 being exploited?

There is no known exploitation of CVE-2022-35513 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-jqhq-pfg3-fg5p.

Is CVE-2022-35513 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free